Ergebnis 1 bis 6 von 6

Thema: MySQL Warnung

  1. #1
    Dyonisus ist offline Routinier
    registriert
    02-03-2001
    Ort
    Braunschweig/Germany
    Beiträge
    259

    MySQL Warnung (neue Frage am Ende :o))

    Warning, to many MySQL connections ...
    Was bedeutet das?
    Steht auf meiner Seite alle paar Tage so hundert mal drauf...
    Geändert von Dyonisus (16-05-2002 um 22:29 Uhr)
    Gruß, Dyonisus

  2. #2
    Avatar von Comet
    Comet ist offline Administrator
    registriert
    17-09-2001
    Ort
    Austria | Westendorf
    Beiträge
    2.182
    Hallo!

    Du mußt deine Verbindungen zur MYSQL-Datenbank auch wieder schließen, wenn die Abfragen beendet sind.
    ..:::Andi:::..

  3. #3
    Dyonisus ist offline Routinier
    registriert
    02-03-2001
    Ort
    Braunschweig/Germany
    Beiträge
    259
    Ahso ...
    Auf der Webseite von der ich meine spärlichen Grundkenntnisse habe, stand das wäre nur notwendig, wenn man mehrere datenbanken nutzt ;o)
    Hab das überall eingebaut und auch ein paar
    mysqll_free_result($ergebnis);
    verteilt. Mal schauen, wird wohl nun weg sein, danke ;o)
    Gruß, Dyonisus

  4. #4
    Dyonisus ist offline Routinier
    registriert
    02-03-2001
    Ort
    Braunschweig/Germany
    Beiträge
    259

    Hilfe!

    Ich habe das Problem leider wieder. Ich beginne die Seite mit
    <?php
    include("connectdb.php")
    ?>
    Da stehen einfach die Verbindungsdaten drin in der Form:

    $verbindung= mysql_connect("...","...","...");
    mysql_select_db("...");

    Dann kommen ein paar Abfragen, dann wieder html Code, wieder php und so weiter, insgesamt ziemlich viel. Erst ganz am Ende schließe ich die Verbindung mit
    mysql_close($verbindung);

    Unter anderem läuft in einem iframe noch dieser Chat:

    <?php
    include("connectdb.php");
    if(isset($insert))
    {
    $time = time();
    $insert=htmlentities($insert);
    $eintrag = "INSERT INTO chat (chatter,message,timestamp) VALUES ('$Band','$insert','$time')";
    $eintragen = mysql_query($eintrag);
    unset($insert);
    }
    $anfrage = "SELECT chatter,message,timestamp FROM chat ORDER BY id DESC LIMIT 20";
    $ergebnisse = mysql_query($anfrage);
    while($row = mysql_fetch_object($ergebnisse))
    {
    $mess = nl2br($row->message);
    $date = date("d.m.Y - H:i:s", $row->timestamp);
    echo "<span style=\"color:#ff0000\">".$row->chatter."</span><span style=\"color:#999999\">[".$date."]</span><br>".$mess."<br><br>";
    }
    mysql_free_result($ergebnisse);
    mysql_close($verbindung);
    ?>

    Das Ding aktualisiert sich standartmäßig alle 20 Sekunden, die Reloadzeit ist aber frei einstellbar.

    Was mache ich da falsch, daß ziemlich häufig die Meldung
    "too many mysql connections in connectdb.php on line 2"
    kommt? Ich schließe die doch immer schön brav ...

    <<<edit>>>
    Ich kann auch mit phpmyadmin die DB nicht mehr erreichen, auch hier warnt er vor zu vielen Verbindungen. Kann ich durch einen Programmierfehler die Datenbank dauerhaft zerschießen, oder liegt das Problem dann eher bei Strato?
    <<<edit ende>>>
    Geändert von Dyonisus (16-05-2002 um 22:28 Uhr)
    Gruß, Dyonisus

  5. #5
    Avatar von Comet
    Comet ist offline Administrator
    registriert
    17-09-2001
    Ort
    Austria | Westendorf
    Beiträge
    2.182
    Hallo!

    Versuch die Verbindungen mal mit einer persistenten DB-Verbindung, dann wird immer nur eine Verbindung geöffnet.

    mysql_pconnect -> Parameter wie gehabt
    ..:::Andi:::..

  6. #6
    Dyonisus ist offline Routinier
    registriert
    02-03-2001
    Ort
    Braunschweig/Germany
    Beiträge
    259

    erledigt

    ... hab gestern 5 Stunden an der Seite gebastelt und die pconnect habsch da auch probiert, hat alles nix geholfen. Nun, irgendwann bekam ioch den entscheidenen Hinweiß, nämlich gut ein Dutzednd Threads erboster User im internen Strato-Forum ;o) Liegt also am Server, nicht an mir ...
    Naja, egal, Hab bei der Fehlersuche viel gelernt und meine Quelltext halbiert *g* Nu schau ich mich mal nach nem anderen Provider um.
    Danke Dir trotzdem!
    Gruß, Dyonisus

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •