Ergebnis 1 bis 6 von 6
  1. #1
    Avatar von wumble
    wumble ist offline Tripel-As
    registriert
    29-08-2005
    Beiträge
    161

    Multi-Upload funktioniert im IE nicht

    Nabend!

    habe folgendes Problem: Habe ein Multi-Upload programmiert das mehrere Dateien hochladen soll. Im Firefox funzt das auch, aber nicht im IE?
    Hab mir das Skript nochmal angeschaut, und auch google bemüht, aber bin da echt überfragt. Vor allem weil das ganze ja über PHP läuft, kein javascript oder so, da dachte ich sollte doch das gleiche beim Server ankommen.

    Naja, also hier mal der Code vom Formular zum Upload:

    *edit: gelöscht ; siehe unten *

    So hier der Code den der Browser ausgibt:

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
      <head>
        <title>Multi-Upload</title>
        <meta http-equiv="content-type" content="text/html; charset=UTF-8" />
        <meta http-equiv="Content-Style-Type" content="text/css" />
        <link href="css/page.css" rel="stylesheet" type="text/css" />
        <link href="css/navi.css" rel="stylesheet" type="text/css" />
        <link href="css/elements.css" rel="stylesheet" type="text/css" />
    
        <link href="css/classes_main.css" rel="stylesheet" type="text/css" />
          </head>
      <body>
        <div id="page">
          <div id="header">
                    <img src="gfx/header.jpg" alt="header.jpg" />      </div>
          <div id="navi_head">
                    <div class="navi_head_block">
    
                <p class="news_head"></p>
                <p class="navi_headline news_link">
                    <a href="?section=news">NEWS</a>
                </p>
            </div>
            <div class="navi_head_block">
                <p class="files_head"></p>
                <p class="navi_headline files_link">
    
                    <a href="?section=upload">DATEIEN</a>
                </p>
            </div>
            <div class="navi_head_block">
                <p class="other_head"></p>
                <p class="navi_headline other_link">
                    <a href="?section=links">SONSTIGES</a>
                </p>
    
            </div>
            <div class="navi_head_block">
                <p class="settings_head"></p>
                <p class="navi_headline settings_link">
                    <a href="?section=hp_settings">EINSTELLUNGEN</a>
                </p>
            </div>
            <div class="navi_head_block">
    
                <p class="options_head"></p>
                <p class="navi_headline options_link">
                    <a href="?section=pw_edit">OPTIONEN</a>
                </p>
            </div>
            <br style="clear:both;" />      </div>
                  <div id="navi_sub" class="files_link">
                <p class="files_head"></p><br style="clear:both;" />
    
                <a href="?section=upload">Upload</a><br />
                <a href="?section=files">Dateien</a><br />
                <a href="?section=gallery">Gallerie</a>
            </div>      <div id="content">            
                        <h2 class="section_headline">Upload</h2><br />
                <br />
    	    <form action="?section=upload" enctype="multipart/form-data" method="post">
    
                    Anzahl der Uploads<br />
                    <input type='text' name='upload_number'  maxlength='2' value='3'   /><br />
                    <br />
                    
    <br /><input type='file' name='file1'   value=''   />
    <br /><input type='file' name='file2'   value=''   />
    <br /><input type='file' name='file3'   value=''   /><br />
    					<span class="error">
    				
    			</span><br />
    		<br />
    
    		<input type='submit' name='upload_new'   value='Hochladen'   />
    	    </form>      </div><br style="clear:both;" />
          <div id="footer">
                    pekko v. b1.0      </div>
        </div>
      </body>
    </html>
    für jede Hilfe oder Anregung wäre ich sehr dankbar!
    Geändert von wumble (29-06-2009 um 00:07 Uhr)
    ...wir können alles machen, alle verrückten Sachen...

  2. #2
    Juppiduh ist offline Doppel-As
    registriert
    17-06-2009
    Beiträge
    143

    AW: Multi-Upload funktioniert im IE nicht

    Keinen Browser interessiert Dein PHP-Zeug - lediglich das, was ihm geschickt wird ist von Relevanz. Poste doch mal den output - der clientseitige Code des Formulars wäre interessant.

  3. #3
    Avatar von wumble
    wumble ist offline Tripel-As
    registriert
    29-08-2005
    Beiträge
    161

    AW: Multi-Upload funktioniert im IE nicht

    oh japs, hab es nun oben geändert. Hatte nur an die PHP-Dateien gedacht, weil diese ja eigentlich das Formular generieren... aber das ergebnis zählt ja bekanntlich.
    ...wir können alles machen, alle verrückten Sachen...

  4. #4
    Avatar von kkapsner
    kkapsner ist offline Super Moderator
    registriert
    28-03-2008
    Beiträge
    17.681

    AW: Multi-Upload funktioniert im IE nicht

    Gib' mal in deinem Action-Attribut den genauen Pfad zur Auswertung an - ev. kann der IE mit "?..." nichts anfangen (oder hat in Formularen Probleme damit).

    Ach und zur Fehlersuche: was heißt - "funktioniert nicht"? Welche Einträge sind in $_POST? ...

  5. #5
    Avatar von pee
    pee
    pee ist offline Doppel-As
    registriert
    13-07-2009
    Beiträge
    138

    AW: Multi-Upload funktioniert im IE nicht

    @wumble:
    Das Forum hat ein Highlighting für HTML. Bitte den Code in die entsprechenden Tags setzen -> Text markieren, HTML-Button klicken. Dann haben auch mehr Leute Lust, sich deinem Code anzunehmen.

  6. #6
    ein schlauer ist offline Lounge-Member
    registriert
    18-08-2004
    Beiträge
    14.671

    AW: Multi-Upload funktioniert im IE nicht

    Zitat Zitat von pee Beitrag anzeigen
    Das Forum hat ein Highlighting für HTML. Bitte den Code in die entsprechenden Tags setzen
    Besser nicht, die Formatierung ist in diesem Forum leider kaputt. Es werden keine bzw. falsche oder auch zuviele Zeilenumbrüche eingebaut. [ PHP ] ist der einzige halbwegs funktionierende Tag

Ähnliche Themen

  1. setAttribute funktioniert in IE7 nicht!
    Von hasher im Forum JavaScript
    Antworten: 10
    Letzter Beitrag: 18-04-2009, 12:33
  2. datei Upload über JS und PHP möglich?
    Von jakez im Forum JavaScript
    Antworten: 0
    Letzter Beitrag: 10-10-2007, 15:29
  3. clientWidth funktioniert nicht im IE
    Von Nussmischung im Forum JavaScript
    Antworten: 5
    Letzter Beitrag: 22-08-2007, 14:50
  4. Antworten: 9
    Letzter Beitrag: 26-06-2007, 04:26
  5. datei(en) upload mit umfangreicher prüfung (PHP)
    Von birdy im Forum Serverseitige Programmierung
    Antworten: 0
    Letzter Beitrag: 26-06-2005, 13:32

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •